package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(%([^%]*)%)`)
var str = `%total_price% and %price% `
var substitution = "{$2}"
fmt.Println(re.ReplaceAllString(str, substitution))
}