$re = '/(%([^%]*)%)/m';
$str = '%total_price% and %price% ';
$subst = "{$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;