import Foundation
let pattern = #"(%([^%]*)%)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"%total_price% and %price% "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{$2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)