use strict;
my $str = '%total_price% and %price% ';
my $regex = qr/(%([^%]*)%)/mp;
my $subst = '{$2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";