# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})(?=\d)/$1-/gm;t' <<< "1111222233334444"