$re = '/(\d{4})(?=\d)/m';
$str = '1111222233334444';
$subst = "$1-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;