import re
regex = re.compile(r"(\d{4})(?=\d)", flags=re.MULTILINE)
test_str = "1111222233334444"
subst = "$1-"
result = regex.sub(subst, test_str)
if result:
print(result)