use strict;
my $str = '1111222233334444';
my $regex = qr/(\d{4})(?=\d)/mp;
my $subst = '$1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";