package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_(.*)_`)
var str = `http://api.com/Location_Republic_of_the_Congo_1000
http://api.com/Location_US_994`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}