$re = '/_(.*)_/m';
$str = 'http://api.com/Location_Republic_of_the_Congo_1000
http://api.com/Location_US_994';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);