const regex = /_(.*)_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(.*)_', 'gm')
const str = `http://api.com/Location_Republic_of_the_Congo_1000
http://api.com/Location_US_994`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}