re = /_(.*)_/m
str = 'http://api.com/Location_Republic_of_the_Congo_1000
http://api.com/Location_US_994'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end