package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-a-z0-9]{0,62}[a-z0-9]$`)
var str = `-ssdfsdfsdfsdfssdfsdfsd-khjkjhkjhk-kjhkjh
-
a-
-a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}