import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-a-z0-9]{0,62}[a-z0-9]$";
final String string = "-ssdfsdfsdfsdfssdfsdfsd-khjkjhkjhk-kjhkjh\n"
+ "-\n"
+ "a-\n"
+ "-a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}