$re = '/^[-a-z0-9]{0,62}[a-z0-9]$/m';
$str = '-ssdfsdfsdfsdfssdfsdfsd-khjkjhkjhk-kjhkjh
-
a-
-a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);