re = /^[-a-z0-9]{0,62}[a-z0-9]$/m
str = '-ssdfsdfsdfsdfssdfsdfsd-khjkjhkjhk-kjhkjh
-
a-
-a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end