using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p.*?</p>(?!\s*<!-- /wp:paragraph -->\s*<!-- wp:paragraph -->)";
string input = @"<!-- wp:paragraph -->
<p>Synonyms replace words like ""<em>positive</em>"" with another <a href=""https://inkforall.com/copy-editing/synonyms/"">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for ""positive"" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like ""<em>positive</em>"" with another <a href=""https://inkforall.com/copy-editing/synonyms/"">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for ""positive"" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like ""<em>positive</em>"" with another <a href=""https://inkforall.com/copy-editing/synonyms/"">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for ""positive"" because so many words can be used instead.</p>
<!-- /wp:paragraph -->";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}