use strict;
my $str = '<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->';
my $regex = qr~<p.*?</p>(?!\s*<!-- /wp:paragraph -->\s*<!-- wp:paragraph -->)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}