$re = '~<p.*?</p>(?!\s*<!-- /wp:paragraph -->\s*<!-- wp:paragraph -->)~m';
$str = '<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);