import Foundation
let pattern = #"<p.*?</p>(?!\s*<!-- /wp:paragraph -->\s*<!-- wp:paragraph -->)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
<!-- wp:paragraph -->
<p>Synonyms replace words like "<em>positive</em>" with another <a href="https://inkforall.com/copy-editing/synonyms/">word or phrase that means the same thing</a> but is more specific. It can be hard to find synonyms for "positive" because so many words can be used instead.</p>
<!-- /wp:paragraph -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)