const regex = /[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}:[\d]{2,5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d]{1,3}\\.[\\d]{1,3}\\.[\\d]{1,3}\\.[\\d]{1,3}:[\\d]{2,5}', 'g')
const str = `<html>
<head></head>
<body>
<pre>
000.000.000.000:0000
000.00.00.000:0000
200.000.000.000:0000
256.000.000.000:00000
192.000.00.000:0000
45.00.0.000:0000
25.00.000.000:00000
255.00.000.00:00000
000.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.0.00.000:00000
000.000.00.00:0000
00.0.000.000:00000
000.00.00.00:0000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.00.000:0000
000.00.00.00:00000
00.00.00.0:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.00.0:00000
00.00.000.00:0000
000.000.000.000:0000
00.00.00.0:0000
00.00.000.00:00000
000.000.000.00:0000
00.000.000.00:0000
000.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.000.000.000:00000
00.000.00.00:00000
00.000.000.000:00000
00.000.000.000:0000
00.00.00.000:0000
00.00.000.00:00000
00.000.000.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.000.000:00000
000.000.000.000:0000
000.00.00.000:00000
00.00.00.000:00000
000.000.000.00:0000
000.000.000.00:0000
00.000.0.00:0000
000.000.00.000:00000
00.000.000.000:00000
00.00.00.000:00000
000.0.000.000:00
000.00.000.000:0000
00.00.000.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
00.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
000.000.000.0:00000
000.000.000.000:0000
00.000.000.00:00000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.0:0000
000.000.00.000:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.00:0000
00.000.000.000:0000
000.00.000.00:0000
00.00.000.000:0000
000.00.000.000:00000
000.00.000.00:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:00000
00.000.000.000:00000
00.000.00.0:0000
000.00.000.00:00000
000.00.00.000:0000
000.000.00.000:0000
00.00.000.00:0000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.00.000:00000
00.00.00.0:0000
000.00.000.00:00
000.000.000.00:0000
000.00.00.000:0000
000.000.000.000:00000
00.000.000.00:0000
000.000.000.000:0000
000.000.000.000:0000
00.00.00.000:0000
00.00.00.000:00000
000.000.00.00:0000
000.00.000.000:00000
00.00.000.00:00000
00.000.0.000:0000
000.000.000.000:0000
00.000.00.0:00000
00.00.000.00:0000
000.000.000.0:0000
000.00.000.00:00000
000.0.000.000:0000
000.00.000.0:00000
000.000.000.00:0000
000.00.00.00:00000
000.000.000.000:0000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.000:0000
00.00.00.0:0000
00.0.000.000:00000
00.000.000.000:00000
00.00.000.00:00000
000.000.00.00:0000
00.00.000.00:00000
000.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:0000
000.000.000.000:00000
00.000.00.0:0000
000.000.000.00:0000
00.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
00.00.00.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:00000
0.00.000.00:00000
000.00.00.00:00000
000.00.000.000:0000
00.000.00.00:00000
000.00.0.000:0000
00.000.00.000:00000
00.000.000.000:00000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.00.000.00:0000
00.00.000.00:0000
00.000.00.0:0000
00.00.00.00:0000
00.000.00.00:00000
00.000.000.00:00000
00.000.00.000:00000
0.00.00.00:0000
000.000.000.000:0000
00.000.000.00:00000
000.00.00.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.000.000:0000
000.000.000.00:0000
00.000.00.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.00.000.000:0000
000.00.0.00:0000
000.00.00.000:0000
000.000.00.000:00000
000.000.00.000:00000
00.0.00.00:00000
000.00.000.00:0000
00.000.000.000:00000
000.000.000.00:0000
00.00.000.00:00000
00.000.000.000:0000
00.00.000.00:00000
00.0.00.000:00000
000.000.000.000:0000
00.00.000.00:00000
000.00.000.00:00000
00.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.00.00:0000
00.000.00.00:00000
00.00.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
00.000.00.00:0000
00.000.00.000:00000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.00:00000
000.00.000.0:00000
000.000.000.000:00000
000.000.000.000:00000
00.000.000.00:00000
00.000.000.00:00000
00.000.000.000:00000
00.000.00.00:0000
000.000.000.000:00
00.00.000.00:0000
00.000.00.00:00000
000.0.000.000:0000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.0:00000
000.00.000.00:00000
000.000.000.000:0000
000.00.00.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.00:0000
000.00.000.000:00000
000.000.00.00:0000
000.000.000.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.000.000:00000
000.00.000.00:00000
00.00.00.000:0000
00.00.000.000:0000
000.000.000.00:00000
000.000.00.000:00000
00.000.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.000.000.00:0000
000.000.000.000:00000
00.000.000.00:00000
000.000.00.000:00000
000.000.00.000:00000
000.000.000.000:0000
000.00.00.00:0000
000.000.00.00:00000
00.000.0.00:0000
000.00.00.000:00000
000.000.000.00:0000
000.000.00.00:0000
00.00.000.00:0000
000.00.000.00:00000
000.00.00.00:00000
00.00.000.000:00000
00.00.000.000:00000
000.000.000.00:0000
00.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.000.00.000:0000
00.0.000.00:00000
000.000.00.000:0000
000.000.00.00:00000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.00:00000
00.00.00.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.000.000:00000
000.00.000.000:0000
000.00.00.000:0000
00.000.000.000:00000
000.000.00.000:0000
00.00.000.000:00000
000.000.000.00:00000
000.00.00.00:0000
000.00.00.00:00000
00.00.00.0:0000
00.00.000.000:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.00.00:00000
000.00.00.00:00000
000.000.000.000:00000
00.000.000.00:0000
000.000.0.000:0000
00.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.00.00.000:0000
00.00.00.000:0000
00.00.000.000:0000
00.000.000.000:00000
000.00.00.00:0000
000.000.00.000:00000
00.00.000.000:0000
000.000.000.000:0000
00.00.00.0:0000
00.000.000.000:0000
000.00.000.000:00000
00.0.000.000:00000
000.00.000.000:0000
000.00.00.00:0000
000.000.000.0:0000
00.00.000.00:0000
00.00.000.00:0000
000.000.000.0:00000
000.00.00.000:0000
000.00.000.000:0000
000.00.00.00:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.000:0000
000.00.00.00:00000
000.000.000.000:0000
000.000.00.00:00000
000.000.00.00:0000
000.000.000.000:0000
000.00.00.000:0000
000.000.000.00:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.000.00.000:0000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.0:0000
00.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:00000
000.000.000.00:0000
000.00.000.00:00000
000.00.00.000:0000
00.00.000.00:00000
00.000.000.000:0000
000.000.000.000:0000
000.000.000.00:00000
00.000.00.0:0000
000.00.000.000:0000
000.000.00.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.00.00.000:00000
000.000.000.0:0000
000.000.0.00:0000
000.000.00.000:0000
0.000.000.000:0000
00.0.00.00:00000
000.000.000.000:0000
00.0.0.000:00000
00.000.00.000:00000
00.00.00.000:00000
000.000.00.000:0000
000.00.00.000:0000
000.00.000.000:0000
000.00.000.00:0000
00.000.00.00:0000
00.00.00.00:0000
000.00.00.00:00000
00.00.00.000:00000
000.00.00.000:00000
000.00.000.000:0000
00.000.000.00:00000
00.000.00.000:00000
00.00.000.00:00000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.00.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
000.000.000.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.0.00.00:00000
000.00.00.00:00000
000.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.000.00:00000
000.000.00.000:0000
000.00.00.00:0000
000.000.00.000:0000
00.00.00.000:0000
000.000.00.000:0000
00.000.000.000:0000
00.000.00.00:00000
000.000.000.00:00000
000.000.00.000:00000
00.00.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.000:0000
00.00.00.000:00000
00.000.0.000:0000
00.00.00.000:0000
00.000.00.000:0000
0.00.000.00:0000
00.000.000.00:00000
00.000.00.000:00000
000.000.00.000:0000
00.00.000.00:0000
000.000.000.000:00000
000.00.00.00:00000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.000.000.00:0000
000.000.0.00:0000
00.000.000.000:0000
00.00.000.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.000.000:0000
00.000.00.00:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.0:0000
000.000.00.00:00000
000.00.00.00:00000
000.00.00.000:00000
00.00.00.000:00000
00.00.000.00:0000
00.000.00.000:0000
000.00.00.00:0000
00.00.000.000:00000
00.000.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
000.000.000.000:0000
000.00.000.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.00.000.000:0000
000.000.00.00:0000
00.000.000.00:0000
00.000.00.00:0000
00.000.00.00:00000
000.00.000.000:0000
000.000.00.000:00000
000.00.000.000:00000
000.00.000.000:0000
000.00.0.00:00000
000.00.00.000:0000
0.000.00.00:00000
000.00.000.00:00000
000.000.00.000:0000
000.0.000.000:00000
00.000.00.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
000.000.00.000:0000
000.000.00.000:0000
00.000.000.00:0000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.000:0000
00.000.000.000:0000
000.000.000.0:0000
000.00.000.000:0000
00.000.00.000:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.00:00000
000.00.00.00:00000
00.000.00.00:0000
00.00.00.00:0000
000.00.000.00:0000
000.000.000.000:0000
000.00.000.00:00000
00.000.00.0:0000
00.000.000.00:0000
000.00.000.00:00000
000.00.000.00:0000
00.00.000.00:0000
000.00.000.000:0000
000.000.0.00:00000
000.000.00.000:0000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.000.000.000:00000
000.000.000.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.000.00:00000
00.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.00.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.000.000.00:0000
000.0.000.00:00000
000.000.00.00:0000
000.000.0.000:00000
000.000.00.000:0000
000.000.00.00:00000
00.000.000.00:0000
00.0.00.0:00000
00.0.00.000:00000
00.00.00.000:0000
000.00.00.00:0000
000.000.00.00:0000
00.00.000.000:00000
000.00.000.000:00000
00.000.0.000:00000
000.00.000.00:00
000.000.000.000:0000
000.000.00.000:0000
00.00.00.000:00000
00.00.000.000:0000
000.000.0.000:000
00.000.000.00:00000
00.000.000.000:0000
00.00.00.00:0000
000.000.00.00:00000
000.000.00.000:00000
000.000.000.000:00000
00.000.00.000:0000
00.00.00.000:00000
00.000.00.000:00000
000.000.00.00:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.00:0000
00.000.00.000:0000
000.00.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.0.00.00:0000
000.000.000.000:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.000.000.00:00000
000.00.000.00:0000
00.00.00.000:00000
000.000.000.00:0000
00.000.00.000:0000
000.000.000.000:00
00.000.000.00:00000
000.0.000.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
000.000.00.000:0000
000.000.000.00:00000
000.00.000.000:0000
000.00.000.0:00000
00.00.000.000:0000
00.000.00.00:0000
000.000.000.000:00000
000.000.00.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.00.000.000:0000
000.000.000.000:0000
0.00.000.000:0000
000.000.00.00:00000
000.000.00.000:0000
00.000.00.000:0000
00.00.000.00:00000
00.000.00.00:0000
000.00.000.000:0000
000.00.00.00:0000
00.000.000.000:00000
00.00.00.000:0000
00.00.000.000:0000
0.0.000.00:0000
0.000.00.000:0000
000.000.000.000:0000
00.0.000.000:00000
00.00.00.00:00000
000.000.000.000:00000
000.00.000.00:00000
000.00.00.000:0000
00.000.000.000:0000
000.00.000.00:00000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.000:0000
000.000.0.00:0000
000.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.00:0000
00.000.00.00:0000
00.000.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:0000
000.000.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.00.00.00:00000
000.000.000.00:0000
000.00.000.000:0000
00.00.000.000:00000
000.000.00.0:0000
00.00.00.000:0000
000.00.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
00.000.0.000:00000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.00.0.00:0000
00.00.000.000:00000
00.00.000.00:0000
000.000.000.000:00000
000.000.00.000:00000
00.000.000.000:0000
000.000.00.000:00000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.00:00000
00.000.000.000:0000
000.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
000.00.000.00:0000
000.000.000.00:0000
000.000.000.000:00000
000.00.00.00:0000
000.00.000.000:0000
000.00.0.000:0000
000.000.000.000:00000
000.00.000.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.000.00.00:00000
000.000.000.000:0000
000.00.00.000:0000
00.0.00.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.00:0000
000.000.00.000:00000
00.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
00.000.000.00:0000
00.000.00.000:0000
000.000.000.00:00000
000.00.000.000:00000
00.000.00.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.00.0.00:0000
0.0.000.000:00000
000.0.000.000:0000
000.000.00.000:00000
00.000.000.000:00000
00.000.000.000:0000
000.00.000.000:00000
00.000.00.00:00000
00.000.000.00:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.000.000:0000
00.0.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
00.000.0.00:0000
00.000.000.000:0000
000.000.000.000:00000
000.00.00.000:0000
00.00.00.000:0000
000.000.000.000:0000
00.0.00.000:0000
00.00.000.000:0000
00.0.00.000:00000
000.00.000.00:00000
000.000.000.00:0000
000.000.00.00:0000
00.000.000.0:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.00.00:0000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.000:0000
000.00.000.0:0000
000.000.00.00:00000
000.000.000.000:0000
00.000.000.00:00000
00.000.000.0:0000
00.00.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
00.00.000.00:0000
000.000.00.000:0000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.00:0000
00.00.000.000:0000
000.00.00.000:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.000.00:00000
000.0.000.000:0000
00.000.000.00:0000
00.00.00.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.00.000.000:00000
00.000.000.000:0000
00.000.000.000:0000
000.00.00.00:0000
000.0.000.000:0000
000.000.000.000:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
00.0.00.000:00000
000.000.000.000:00000
000.000.000.000:00000
000.000.000.00:0000
000.00.00.000:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.00.00.000:00000
0.00.000.000:0000
000.000.00.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.000.000.00:00
000.00.000.0:0000
000.000.00.00:0000
000.00.000.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.00.000:00000
00.000.00.00:0000
00.000.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.00.00.000:0000
00.0.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.00.000:0000
00.000.000.00:0000
000.000.00.000:00000
000.000.0.00:00000
000.000.000.000:0000
00.000.00.000:00000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.00.00:00000
00.000.0.0:00000
000.000.000.000:0000
00.000.000.0:00000
000.00.000.00:0000
000.00.00.000:00000
000.000.00.000:0000
00.00.00.0:0000
00.00.000.00:00000
00.00.00.000:00000
00.000.00.000:00000
000.00.000.000:00000
00.000.00.00:00000
00.00.00.000:00000
000.00.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.000.00.000:0000
000.00.000.000:00000
000.000.00.000:00000
00.000.00.00:00000
000.000.000.000:0000
000.000.0.00:00000
00.000.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
00.000.00.000:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.0:00000
000.00.00.00:00000
000.000.00.00:0000
000.000.000.00:0000
00.00.000.00:00000
000.00.00.00:00000
000.000.000.00:00000
000.000.00.00:00000
00.000.000.00:00000
000.000.000.00:0000
000.000.000.00:0000
00.00.00.000:0000
000.00.000.00:0000
00.000.00.00:00000
00.000.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
00.0.000.000:00000
000.000.000.00:00000
00.000.000.000:00000
000.000.000.00:0000
00.00.00.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.00.00:00000
000.000.000.000:0000
00.00.00.0:0000
00.0.0.000:00000
000.00.0.00:0000
00.00.00.00:00000
000.00.000.00:0000
000.00.00.00:0000
000.000.000.000:0000
000.00.00.000:00000
000.000.00.000:00000
000.000.000.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.000.000:00000
000.000.000.0:00000
00.00.00.00:0000
00.000.000.000:00000
000.000.000.000:00000
000.000.00.00:0000
00.00.000.000:00000
000.00.00.000:00000
000.000.000.000:0000
00.00.00.00:00000
000.000.000.0:0000
000.000.000.000:0000
000.000.000.000:0000
</pre>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}