// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}:[\d]{2,5}").unwrap();
let string = "<html>
<head></head>
<body>
<pre>
000.000.000.000:0000
000.00.00.000:0000
200.000.000.000:0000
256.000.000.000:00000
192.000.00.000:0000
45.00.0.000:0000
25.00.000.000:00000
255.00.000.00:00000
000.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.0.00.000:00000
000.000.00.00:0000
00.0.000.000:00000
000.00.00.00:0000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.00.000:0000
000.00.00.00:00000
00.00.00.0:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.00.0:00000
00.00.000.00:0000
000.000.000.000:0000
00.00.00.0:0000
00.00.000.00:00000
000.000.000.00:0000
00.000.000.00:0000
000.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.000.000.000:00000
00.000.00.00:00000
00.000.000.000:00000
00.000.000.000:0000
00.00.00.000:0000
00.00.000.00:00000
00.000.000.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.000.000:00000
000.000.000.000:0000
000.00.00.000:00000
00.00.00.000:00000
000.000.000.00:0000
000.000.000.00:0000
00.000.0.00:0000
000.000.00.000:00000
00.000.000.000:00000
00.00.00.000:00000
000.0.000.000:00
000.00.000.000:0000
00.00.000.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
00.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
000.000.000.0:00000
000.000.000.000:0000
00.000.000.00:00000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.0:0000
000.000.00.000:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.000.00:0000
00.000.000.000:0000
000.00.000.00:0000
00.00.000.000:0000
000.00.000.000:00000
000.00.000.00:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:00000
00.000.000.000:00000
00.000.00.0:0000
000.00.000.00:00000
000.00.00.000:0000
000.000.00.000:0000
00.00.000.00:0000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.00.000:00000
00.00.00.0:0000
000.00.000.00:00
000.000.000.00:0000
000.00.00.000:0000
000.000.000.000:00000
00.000.000.00:0000
000.000.000.000:0000
000.000.000.000:0000
00.00.00.000:0000
00.00.00.000:00000
000.000.00.00:0000
000.00.000.000:00000
00.00.000.00:00000
00.000.0.000:0000
000.000.000.000:0000
00.000.00.0:00000
00.00.000.00:0000
000.000.000.0:0000
000.00.000.00:00000
000.0.000.000:0000
000.00.000.0:00000
000.000.000.00:0000
000.00.00.00:00000
000.000.000.000:0000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.000:0000
00.00.00.0:0000
00.0.000.000:00000
00.000.000.000:00000
00.00.000.00:00000
000.000.00.00:0000
00.00.000.00:00000
000.000.000.00:0000
000.000.000.000:0000
000.00.000.000:0000
00.000.00.00:00000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.000:0000
000.000.000.000:00000
00.000.00.0:0000
000.000.000.00:0000
00.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
000.00.000.00:0000
00.00.00.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:00000
0.00.000.00:00000
000.00.00.00:00000
000.00.000.000:0000
00.000.00.00:00000
000.00.0.000:0000
00.000.00.000:00000
00.000.000.000:00000
000.00.00.000:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.00.000.00:0000
00.00.000.00:0000
00.000.00.0:0000
00.00.00.00:0000
00.000.00.00:00000
00.000.000.00:00000
00.000.00.000:00000
0.00.00.00:0000
000.000.000.000:0000
00.000.000.00:00000
000.00.00.000:0000
000.000.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.000.000:0000
000.000.000.00:0000
00.000.00.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.00.000.000:0000
000.00.0.00:0000
000.00.00.000:0000
000.000.00.000:00000
000.000.00.000:00000
00.0.00.00:00000
000.00.000.00:0000
00.000.000.000:00000
000.000.000.00:0000
00.00.000.00:00000
00.000.000.000:0000
00.00.000.00:00000
00.0.00.000:00000
000.000.000.000:0000
00.00.000.00:00000
000.00.000.00:00000
00.00.00.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.00.00:0000
00.000.00.00:00000
00.00.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
00.000.00.00:0000
00.000.00.000:00000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.00:00000
000.00.000.0:00000
000.000.000.000:00000
000.000.000.000:00000
00.000.000.00:00000
00.000.000.00:00000
00.000.000.000:00000
00.000.00.00:0000
000.000.000.000:00
00.00.000.00:0000
00.000.00.00:00000
000.0.000.000:0000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.00:00000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.0:00000
000.00.000.00:00000
000.000.000.000:0000
000.00.00.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.000.000.00:0000
000.00.000.000:00000
000.000.00.00:0000
000.000.000.0:0000
000.000.00.000:0000
000.000.000.000:00000
00.000.000.000:00000
000.00.000.00:00000
00.00.00.000:0000
00.00.000.000:0000
000.000.000.00:00000
000.000.00.000:00000
00.000.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.000.000.00:0000
000.000.000.000:00000
00.000.000.00:00000
000.000.00.000:00000
000.000.00.000:00000
000.000.000.000:0000
000.00.00.00:0000
000.000.00.00:00000
00.000.0.00:0000
000.00.00.000:00000
000.000.000.00:0000
000.000.00.00:0000
00.00.000.00:0000
000.00.000.00:00000
000.00.00.00:00000
00.00.000.000:00000
00.00.000.000:00000
000.000.000.00:0000
00.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.00:0000
000.000.000.000:0000
00.000.00.000:0000
00.0.000.00:00000
000.000.00.000:0000
000.000.00.00:00000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.000:0000
000.00.000.00:00000
00.00.00.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.000.000:00000
000.00.000.000:0000
000.00.00.000:0000
00.000.000.000:00000
000.000.00.000:0000
00.00.000.000:00000
000.000.000.00:00000
000.00.00.00:0000
000.00.00.00:00000
00.00.00.0:0000
00.00.000.000:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.00.00:00000
000.00.00.00:00000
000.000.000.000:00000
00.000.000.00:0000
000.000.0.000:0000
00.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
000.00.000.000:0000
000.00.00.000:0000
00.00.00.000:0000
00.00.000.000:0000
00.000.000.000:00000
000.00.00.00:0000
000.000.00.000:00000
00.00.000.000:0000
000.000.000.000:0000
00.00.00.0:0000
00.000.000.000:0000
000.00.000.000:00000
00.0.000.000:00000
000.00.000.000:0000
000.00.00.00:0000
000.000.000.0:0000
00.00.000.00:0000
00.00.000.00:0000
000.000.000.0:00000
000.00.00.000:0000
000.00.000.000:0000
000.00.00.00:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.000:0000
000.00.00.00:00000
000.000.000.000:0000
000.000.00.00:00000
000.000.00.00:0000
000.000.000.000:0000
000.00.00.000:0000
000.000.000.00:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.000.00.000:0000
000.00.000.00:00000
000.00.000.00:0000
000.00.000.0:0000
00.000.000.000:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:00000
000.000.000.00:0000
000.00.000.00:00000
000.00.00.000:0000
00.00.000.00:00000
00.000.000.000:0000
000.000.000.000:0000
000.000.000.00:00000
00.000.00.0:0000
000.00.000.000:0000
000.000.00.000:00000
00.00.00.000:0000
00.000.000.00:0000
000.00.00.000:00000
000.000.000.0:0000
000.000.0.00:0000
000.000.00.000:0000
0.000.000.000:0000
00.0.00.00:00000
000.000.000.000:0000
00.0.0.000:00000
00.000.00.000:00000
00.00.00.000:00000
000.000.00.000:0000
000.00.00.000:0000
000.00.000.000:0000
000.00.000.00:0000
00.000.00.00:0000
00.00.00.00:0000
000.00.00.00:00000
00.00.00.000:00000
000.00.00.000:00000
000.00.000.000:0000
00.000.000.00:00000
00.000.00.000:00000
00.00.000.00:00000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.00.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.00.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
000.000.000.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
000.0.00.00:00000
000.00.00.00:00000
000.00.000.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.000.00:00000
000.000.00.000:0000
000.00.00.00:0000
000.000.00.000:0000
00.00.00.000:0000
000.000.00.000:0000
00.000.000.000:0000
00.000.00.00:00000
000.000.000.00:00000
000.000.00.000:00000
00.00.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.000:0000
00.00.00.000:00000
00.000.0.000:0000
00.00.00.000:0000
00.000.00.000:0000
0.00.000.00:0000
00.000.000.00:00000
00.000.00.000:00000
000.000.00.000:0000
00.00.000.00:0000
000.000.000.000:00000
000.00.00.00:00000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.000.000.00:0000
000.000.0.00:0000
00.000.000.000:0000
00.00.000.000:0000
000.00.000.000:0000
000.000.000.00:0000
000.00.000.000:0000
00.000.00.00:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.0:0000
000.000.00.0:0000
000.000.00.00:00000
000.00.00.00:00000
000.00.00.000:00000
00.00.00.000:00000
00.00.000.00:0000
00.000.00.000:0000
000.00.00.00:0000
00.00.000.000:00000
00.000.000.00:00000
000.00.000.0:0000
000.000.00.000:0000
000.000.000.000:0000
000.00.000.000:00000
000.00.00.00:00000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.00.000.000:0000
000.000.00.00:0000
00.000.000.00:0000
00.000.00.00:0000
00.000.00.00:00000
000.00.000.000:0000
000.000.00.000:00000
000.00.000.000:00000
000.00.000.000:0000
000.00.0.00:00000
000.00.00.000:0000
0.000.00.00:00000
000.00.000.00:00000
000.000.00.000:0000
000.0.000.000:00000
00.000.00.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
000.000.00.000:0000
000.000.00.000:0000
00.000.000.00:0000
000.00.00.00:00000
000.00.000.000:0000
000.00.000.000:0000
00.000.000.000:0000
000.000.000.0:0000
000.00.000.000:0000
00.000.00.000:0000
000.00.000.000:0000
000.000.000.0:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.00:00000
000.00.00.00:00000
00.000.00.00:0000
00.00.00.00:0000
000.00.000.00:0000
000.000.000.000:0000
000.00.000.00:00000
00.000.00.0:0000
00.000.000.00:0000
000.00.000.00:00000
000.00.000.00:0000
00.00.000.00:0000
000.00.000.000:0000
000.000.0.00:00000
000.000.00.000:0000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.000.000.000:00000
000.000.000.000:0000
000.000.00.00:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.000.00:00000
00.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.00.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.000.000.00:0000
000.0.000.00:00000
000.000.00.00:0000
000.000.0.000:00000
000.000.00.000:0000
000.000.00.00:00000
00.000.000.00:0000
00.0.00.0:00000
00.0.00.000:00000
00.00.00.000:0000
000.00.00.00:0000
000.000.00.00:0000
00.00.000.000:00000
000.00.000.000:00000
00.000.0.000:00000
000.00.000.00:00
000.000.000.000:0000
000.000.00.000:0000
00.00.00.000:00000
00.00.000.000:0000
000.000.0.000:000
00.000.000.00:00000
00.000.000.000:0000
00.00.00.00:0000
000.000.00.00:00000
000.000.00.000:00000
000.000.000.000:00000
00.000.00.000:0000
00.00.00.000:00000
00.000.00.000:00000
000.000.00.00:0000
000.000.000.000:0000
000.000.00.000:0000
000.000.000.00:0000
00.000.00.000:0000
000.00.0.000:0000
000.000.000.00:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.00.000:0000
000.000.000.000:0000
000.00.000.00:0000
00.0.00.00:0000
000.000.000.000:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.000.000.00:00000
000.00.000.00:0000
00.00.00.000:00000
000.000.000.00:0000
00.000.00.000:0000
000.000.000.000:00
00.000.000.00:00000
000.0.000.000:0000
000.00.000.000:0000
000.000.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
000.000.00.000:0000
000.000.000.00:00000
000.00.000.000:0000
000.00.000.0:00000
00.00.000.000:0000
00.000.00.00:0000
000.000.000.000:00000
000.000.00.00:0000
00.000.00.000:0000
00.000.00.00:0000
000.00.000.000:0000
000.000.000.000:0000
0.00.000.000:0000
000.000.00.00:00000
000.000.00.000:0000
00.000.00.000:0000
00.00.000.00:00000
00.000.00.00:0000
000.00.000.000:0000
000.00.00.00:0000
00.000.000.000:00000
00.00.00.000:0000
00.00.000.000:0000
0.0.000.00:0000
0.000.00.000:0000
000.000.000.000:0000
00.0.000.000:00000
00.00.00.00:00000
000.000.000.000:00000
000.00.000.00:00000
000.00.00.000:0000
00.000.000.000:0000
000.00.000.00:00000
00.00.00.000:0000
000.00.00.000:0000
000.000.000.000:0000
000.000.0.00:0000
000.000.00.00:0000
000.000.000.00:0000
000.00.000.000:0000
000.000.000.00:0000
00.000.00.00:0000
00.000.00.00:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.000.000:0000
000.000.00.000:0000
00.000.000.000:0000
000.000.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.00.00.00:00000
000.000.000.00:0000
000.00.000.000:0000
00.00.000.000:00000
000.000.00.0:0000
00.00.00.000:0000
000.00.000.00:00000
000.000.000.000:00000
00.000.000.000:00000
00.000.0.000:00000
000.000.000.000:0000
000.00.000.00:0000
00.00.00.00:0000
000.000.000.00:0000
000.000.000.00:00000
000.00.00.00:0000
000.00.0.00:0000
00.00.000.000:00000
00.00.000.00:0000
000.000.000.000:00000
000.000.00.000:00000
00.000.000.000:0000
000.000.00.000:00000
00.000.000.000:0000
000.00.000.00:0000
000.00.000.00:00000
00.000.000.000:0000
000.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
000.00.000.00:0000
000.000.000.00:0000
000.000.000.000:00000
000.00.00.00:0000
000.00.000.000:0000
000.00.0.000:0000
000.000.000.000:00000
000.00.000.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.000.00:0000
000.000.00.00:00000
000.000.000.000:0000
000.00.00.000:0000
00.0.00.00:00000
000.000.000.000:0000
000.00.000.000:0000
00.00.000.00:0000
000.000.00.00:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.00:0000
000.000.00.000:00000
00.0.00.000:00000
000.00.00.000:00000
00.00.000.000:0000
00.000.000.00:0000
00.000.00.000:0000
000.000.000.00:00000
000.00.000.000:00000
00.000.00.00:0000
000.000.00.000:0000
000.000.00.000:0000
000.00.0.00:0000
0.0.000.000:00000
000.0.000.000:0000
000.000.00.000:00000
00.000.000.000:00000
00.000.000.000:0000
000.00.000.000:00000
00.000.00.00:00000
00.000.000.00:00000
000.00.00.00:00000
00.000.000.00:0000
000.000.000.000:0000
00.0.00.00:00000
000.00.000.000:0000
00.000.000.00:0000
00.000.0.00:0000
00.000.000.000:0000
000.000.000.000:00000
000.00.00.000:0000
00.00.00.000:0000
000.000.000.000:0000
00.0.00.000:0000
00.00.000.000:0000
00.0.00.000:00000
000.00.000.00:00000
000.000.000.00:0000
000.000.00.00:0000
00.000.000.0:0000
000.00.000.000:0000
000.000.00.000:0000
000.000.00.00:0000
00.000.00.00:0000
000.00.000.00:0000
00.000.00.000:0000
00.000.00.000:0000
000.00.000.0:0000
000.000.00.00:00000
000.000.000.000:0000
00.000.000.00:00000
00.000.000.0:0000
00.00.000.00:0000
000.000.00.00:0000
000.000.000.000:0000
00.00.000.00:0000
000.000.00.000:0000
000.000.00.000:00000
000.00.000.00:0000
000.000.00.00:0000
00.00.000.000:0000
000.00.00.000:0000
000.00.000.000:0000
00.000.000.000:00000
000.00.000.00:00000
000.0.000.000:0000
00.000.000.00:0000
00.00.00.000:0000
000.00.000.00:00000
000.00.000.0:0000
000.00.000.000:00000
00.000.000.000:0000
00.000.000.000:0000
000.00.00.00:0000
000.0.000.000:0000
000.000.000.000:00000
000.00.000.000:0000
00.00.00.000:0000
000.000.000.000:00000
00.0.00.000:00000
000.000.000.000:00000
000.000.000.000:00000
000.000.000.00:0000
000.00.00.000:0000
00.00.00.000:0000
00.000.000.000:0000
00.000.00.00:0000
000.00.00.000:00000
0.00.000.000:0000
000.000.00.00:0000
000.000.00.00:0000
000.00.000.000:0000
000.00.000.000:0000
000.00.00.00:0000
00.00.00.000:0000
00.000.000.00:00
000.00.000.0:0000
000.000.00.00:0000
000.00.000.0:0000
000.000.00.00:0000
000.00.00.000:00000
00.000.00.000:00000
00.000.00.00:0000
00.000.000.000:0000
000.000.00.000:0000
000.000.000.00:00000
00.00.00.000:0000
00.0.00.00:00000
000.000.000.00:00000
000.000.000.000:0000
000.000.000.000:0000
000.00.000.0:00000
000.000.00.000:0000
00.000.000.00:0000
000.000.00.000:00000
000.000.0.00:00000
000.000.000.000:0000
00.000.00.000:00000
00.000.00.000:00000
00.00.00.00:0000
000.00.000.000:0000
00.00.00.000:0000
00.000.000.00:00000
000.00.00.000:00000
000.00.00.00:00000
00.000.0.0:00000
000.000.000.000:0000
00.000.000.0:00000
000.00.000.00:0000
000.00.00.000:00000
000.000.00.000:0000
00.00.00.0:0000
00.00.000.00:00000
00.00.00.000:00000
00.000.00.000:00000
000.00.000.000:00000
00.000.00.00:00000
00.00.00.000:00000
000.00.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
000.00.000.000:0000
000.00.000.000:0000
000.000.000.00:00000
000.00.00.00:00000
00.000.000.000:0000
000.000.00.000:0000
000.00.000.000:00000
000.000.00.000:00000
00.000.00.00:00000
000.000.000.000:0000
000.000.0.00:00000
00.000.000.00:00000
000.00.00.000:00000
000.000.000.000:0000
00.000.00.000:00000
000.000.00.00:0000
00.000.000.00:0000
00.000.000.000:00000
000.00.00.000:00000
000.00.00.0:00000
000.00.00.00:00000
000.000.00.00:0000
000.000.000.00:0000
00.00.000.00:00000
000.00.00.00:00000
000.000.000.00:00000
000.000.00.00:00000
00.000.000.00:00000
000.000.000.00:0000
000.000.000.00:0000
00.00.00.000:0000
000.00.000.00:0000
00.000.00.00:00000
00.000.000.000:00000
000.000.000.000:0000
000.000.000.00:0000
00.0.000.000:00000
000.000.000.00:00000
00.000.000.000:00000
000.000.000.00:0000
00.00.00.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.00.00:00000
000.000.000.000:0000
00.00.00.0:0000
00.0.0.000:00000
000.00.0.00:0000
00.00.00.00:00000
000.00.000.00:0000
000.00.00.00:0000
000.000.000.000:0000
000.00.00.000:00000
000.000.00.000:00000
000.000.000.00:0000
00.000.000.000:00000
00.000.00.000:00000
000.00.000.000:00000
000.000.000.0:00000
00.00.00.00:0000
00.000.000.000:00000
000.000.000.000:00000
000.000.00.00:0000
00.00.000.000:00000
000.00.00.000:00000
000.000.000.000:0000
00.00.00.00:00000
000.000.000.0:0000
000.000.000.000:0000
000.000.000.000:0000
</pre>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}