using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^#%^&*\][}{=+\\|><\`~]*$";
string input = @"This is a test to see if it works. I want to accept any string that doesn't have
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}