$re = '/^[^#%^&*\][}{=+\\\\|><\`~]*$/';
$str = 'This is a test to see if it works. I want to accept any string that doesn\'t have
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);