package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^#%^&*\][}{=+\\|><\`~]*$`)
var str = `This is a test to see if it works. I want to accept any string that doesn't have
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}