re = /^[^#%^&*\][}{=+\\|><\`~]*$/
str = 'This is a test to see if it works. I want to accept any string that doesn\'t have
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end