#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.(?! (?=[MDCLXVI])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+\S?"
Local $sString = "Joe" & @CRLF & _
"Bob" & @CRLF & _
"Carl" & @CRLF & _
"Seth Smith II" & @CRLF & _
"Doug IV" & @CRLF & _
"" & @CRLF & _
"John Doe LIV" & @CRLF & _
"Jane Black MMXIX" & @CRLF & _
"Francis LIVERPOOL" & @CRLF & _
"Maragaret White MCMLXXXIV" & @CRLF & _
"Jennifer Brown DIX" & @CRLF & _
"Jet LI II" & @CRLF & _
"Jet LI" & @CRLF & _
"Jeniffer Li VII" & @CRLF & _
"Jorge Fernandondo Gutiérrez Fernández XIII" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")