const regex = /^(?:.(?! (?=[MDCLXVI])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+\S?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.(?! (?=[MDCLXVI])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+\\S?', 'mg')
const str = `Joe
Bob
Carl
Seth Smith II
Doug IV
John Doe LIV
Jane Black MMXIX
Francis LIVERPOOL
Maragaret White MCMLXXXIV
Jennifer Brown DIX
Jet LI II
Jet LI
Jeniffer Li VII
Jorge Fernandondo Gutiérrez Fernández XIII
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}