$re = '/^(?:.(?! (?=[MDCLXVI])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+\S?/m';
$str = 'Joe
Bob
Carl
Seth Smith II
Doug IV
John Doe LIV
Jane Black MMXIX
Francis LIVERPOOL
Maragaret White MCMLXXXIV
Jennifer Brown DIX
Jet LI II
Jet LI
Jeniffer Li VII
Jorge Fernandondo Gutiérrez Fernández XIII
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);