import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.(?! (?=[MDCLXVI])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+\\S?";
final String string = "Joe\n"
+ "Bob\n"
+ "Carl\n"
+ "Seth Smith II\n"
+ "Doug IV\n\n"
+ "John Doe LIV\n"
+ "Jane Black MMXIX\n"
+ "Francis LIVERPOOL\n"
+ "Maragaret White MCMLXXXIV\n"
+ "Jennifer Brown DIX\n"
+ "Jet LI II\n"
+ "Jet LI\n"
+ "Jeniffer Li VII\n"
+ "Jorge Fernandondo Gutiérrez Fernández XIII\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}