#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)((?: |^)([\p{L}\p{M}])\2+(?= |$))|([\p{L}\p{M}])(?=\3)"
Local $sString = "aaa baaab xxx" & @CRLF & _
"ahhj aaab cc iiik" & @CRLF & _
"bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa" & @CRLF & _
"" & @CRLF & _
"#$aa$aa#aaa bbb" & @CRLF & _
"aaa aaa" & @CRLF & _
"" & @CRLF & _
"test aaaaa aaaaa aaaa" & @CRLF & _
" aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz" & @CRLF & _
"ááá áább çç ççç ábbá"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)