using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?: |^)([\p{L}\p{M}])\2+(?= |$))|([\p{L}\p{M}])(?=\3)";
string substitution = @"$1";
string input = @"aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#$aa$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz
ááá áább çç ççç ábbá";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}