import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?: |^)([\\p{L}\\p{M}])\\2+(?= |$))|([\\p{L}\\p{M}])(?=\\3)";
final String string = "aaa baaab xxx\n"
+ "ahhj aaab cc iiik\n"
+ "bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa\n\n"
+ "#$aa$aa#aaa bbb\n"
+ "aaa aaa\n\n"
+ "test aaaaa aaaaa aaaa\n"
+ " aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz\n"
+ "ááá áább çç ççç ábbá";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}