#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*s|Alla dagar)(?=(?<from>\d+) ?- ?(?<to>\d+)).*$"
Local $sString = "### Sign 1 - Should match" & @CRLF & _
"8-17" & @CRLF & _
"Alla dagar" & @CRLF & _
"" & @CRLF & _
"### Sign 2 - Should match" & @CRLF & _
"Alla dagar" & @CRLF & _
"08-21" & @CRLF & _
"" & @CRLF & _
"### Sign 3 - Should not match" & @CRLF & _
"8-17" & @CRLF & _
"" & @CRLF & _
"### Sign 4 - Should mathc" & @CRLF & _
"7 - 9 Alla dagar" & @CRLF & _
"" & @CRLF & _
"### Sign 5 - Should match" & @CRLF & _
"Alla dagar 17-23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")