const regex = /^(?=.*s|Alla dagar)(?=(?<from>\d+) ?- ?(?<to>\d+)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*s|Alla dagar)(?=(?<from>\\d+) ?- ?(?<to>\\d+)).*$', 'gm')
const str = `### Sign 1 - Should match
8-17
Alla dagar
### Sign 2 - Should match
Alla dagar
08-21
### Sign 3 - Should not match
8-17
### Sign 4 - Should mathc
7 - 9 Alla dagar
### Sign 5 - Should match
Alla dagar 17-23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}