use strict;
my $str = '### Sign 1 - Should match
8-17
Alla dagar
### Sign 2 - Should match
Alla dagar
08-21
### Sign 3 - Should not match
8-17
### Sign 4 - Should mathc
7 - 9 Alla dagar
### Sign 5 - Should match
Alla dagar 17-23';
my $regex = qr/^(?=.*s|Alla dagar)(?=(?<from>\d+) ?- ?(?<to>\d+)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}