# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*s|Alla dagar)(?=(?<from>\d+) ?- ?(?<to>\d+)).*$"
test_str = ("### Sign 1 - Should match\n"
"8-17\n"
"Alla dagar\n\n"
"### Sign 2 - Should match\n"
"Alla dagar\n"
"08-21\n\n"
"### Sign 3 - Should not match\n"
"8-17\n\n"
"### Sign 4 - Should mathc\n"
"7 - 9 Alla dagar\n\n"
"### Sign 5 - Should match\n"
"Alla dagar 17-23")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.