const regex = /(\S+)(?=\s+\b(\d{2}([-/ .])\d{2}\3\d{4})\b(?!.*\b\d{2}([-/ .])\d{2}\4\d{4}\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+)(?=\\s+\\b(\\d{2}([-\/ .])\\d{2}\\3\\d{4})\\b(?!.*\\b\\d{2}([-\/ .])\\d{2}\\4\\d{4}\\b))', 'gm')
const str = `Florida 03/22/2022 04/05/2022 Bid Support Help Desk is glad to assist you
Florida 04/05/2022 Bid Support Help Desk is glad to assist you`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}