use strict;
my $str = 'Florida 03/22/2022 04/05/2022 Bid Support Help Desk is glad to assist you
Florida 04/05/2022 Bid Support Help Desk is glad to assist you';
my $regex = qr/(\S+)(?=\s+\b(\d{2}([-/ .])\d{2}\3\d{4})\b(?!.*\b\d{2}([-/ .])\d{2}\4\d{4}\b))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}