import re
regex = re.compile(r"(\S+)(?=\s+\b(\d{2}([-/ .])\d{2}\3\d{4})\b(?!.*\b\d{2}([-/ .])\d{2}\4\d{4}\b))", flags=re.MULTILINE)
test_str = ("Florida 03/22/2022 04/05/2022 Bid Support Help Desk is glad to assist you\n\n"
"Florida 04/05/2022 Bid Support Help Desk is glad to assist you")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")