re = /(\S+)(?=\s+\b(\d{2}([-\/ .])\d{2}\3\d{4})\b(?!.*\b\d{2}([-\/ .])\d{2}\4\d{4}\b))/m
str = 'Florida 03/22/2022 04/05/2022 Bid Support Help Desk is glad to assist you
Florida 04/05/2022 Bid Support Help Desk is glad to assist you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end