#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bfilename=[",/]*([^/\s"=\][][^/"=\][]*)"
Local $sString = "["attachment; filename=","New Microsoft Excel Worksheet.xlsx",""]t" & @CRLF & _
"["attachment; filename=","/New Microsoft Excel Worksheet.xlsx/",""]" & @CRLF & _
"["attachment; filename="jimmy.xlsx""]" & @CRLF & _
"["attachment; filename=jimmy.xlsx]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")