package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bfilename=[",/]*([^/\s"=\][][^/"=\][]*)`)
var str = `["attachment; filename=","New Microsoft Excel Worksheet.xlsx",""]t
["attachment; filename=","/New Microsoft Excel Worksheet.xlsx/",""]
["attachment; filename="jimmy.xlsx""]
["attachment; filename=jimmy.xlsx]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}