$re = '~\bfilename=[",/]*([^/\s"=\][][^/"=\][]*)~m';
$str = '["attachment; filename=","New Microsoft Excel Worksheet.xlsx",""]t
["attachment; filename=","/New Microsoft Excel Worksheet.xlsx/",""]
["attachment; filename="jimmy.xlsx""]
["attachment; filename=jimmy.xlsx]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);