import re
regex = re.compile(r"\bfilename=[\",/]*([^/\s\"=\][][^/\"=\][]*)", flags=re.MULTILINE)
test_str = ("[\"attachment; filename=\",\"New Microsoft Excel Worksheet.xlsx\",\"\"]t\n"
"[\"attachment; filename=\",\"/New Microsoft Excel Worksheet.xlsx/\",\"\"]\n"
"[\"attachment; filename=\"jimmy.xlsx\"\"]\n"
"[\"attachment; filename=jimmy.xlsx]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")