$re = '/[a-z A-z () /]/m';
$str = '/Date(123456789)/
A-z considera esses caracteres: []^\\_
e remove os espaços: 1234 567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;