import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)\\1$";
final String string = "customer servicescustomer services\n"
+ "House of FraserHouse of Fraser\n"
+ "Managing DirectorManaging Director\n"
+ "Adebanbutayo Trading StoresAdebanbutayo Trading Stores\n"
+ "Jan 2012 - Present · 10 yrs 2 mosJan 2012 - Present · 10 yrs 2 mos";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}