import re
regex = re.compile(r"^(.+)\1$", flags=re.MULTILINE)
test_str = ("customer servicescustomer services\n"
"House of FraserHouse of Fraser\n"
"Managing DirectorManaging Director\n"
"Adebanbutayo Trading StoresAdebanbutayo Trading Stores\n"
"Jan 2012 - Present · 10 yrs 2 mosJan 2012 - Present · 10 yrs 2 mos")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)