re = /^(.+)\1$/m
str = 'customer servicescustomer services
House of FraserHouse of Fraser
Managing DirectorManaging Director
Adebanbutayo Trading StoresAdebanbutayo Trading Stores
Jan 2012 - Present · 10 yrs 2 mosJan 2012 - Present · 10 yrs 2 mos'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result