#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<index>\d)\nEA\n\s(?<quantity>[0-9\.]+)\s(?<partNumber>[0-9A-Z-]+)\s(?<unknonw1>[0-9\.]+)\s(?<unknonw2>[0-9\.]+)\n(?<partName>[A-Z\s]+)\nDrawing\:\s(?<drawing>[A-Z]+)\nDue\:\s(?<date>[0-9]+\/[0-9]+\/[0-9]+)\sRequester\:\s(?<requester>[A-Z]+)\nOrder\:\s(?<order>[0-9A-Z-]+)\sSeq\sNo\:\s(?<sequence>[0-9]+)$"
Local $sString = "1" & @CRLF & _
"EA" & @CRLF & _
" 2.00 2814-212-D003 0.00 0.00" & @CRLF & _
"LONG JACK PAD" & @CRLF & _
"Drawing: OPT" & @CRLF & _
"Due: 05/19/2023 Requester: NMB" & @CRLF & _
"Order: 2843HR-213-703 Seq No: 9002" & @CRLF & _
"2" & @CRLF & _
"EA" & @CRLF & _
" 2.00 2814-212-D003 0.00 0.00" & @CRLF & _
"LONG JACK PAD" & @CRLF & _
"Drawing: OPT" & @CRLF & _
"Due: 05/19/2023 Requester: NMB" & @CRLF & _
"Order: 2843HR-214-703 Seq No: 9002" & @CRLF & _
"3" & @CRLF & _
"EA" & @CRLF & _
" 2.00 2814-212-D004 0.00 0.00" & @CRLF & _
"SHORT JACK PAD" & @CRLF & _
"Drawing: OPT" & @CRLF & _
"Due: 05/19/2023 Requester: NMB" & @CRLF & _
"Order: 2843HR-213-703 Seq No: 9003" & @CRLF & _
"4" & @CRLF & _
"EA" & @CRLF & _
" 2.00 2814-212-D004 0.00 0.00" & @CRLF & _
"SHORT JACK PAD" & @CRLF & _
"Drawing: OPT" & @CRLF & _
"Due: 05/19/2023 Requester: NMB" & @CRLF & _
"Order: 2843HR-214-703 Seq No: 9003"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")